5412 COO Programming Manual: C:/COO Directory Reference

5412 COO Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members

COO Directory Reference

Files

         JY5412CoreOOCommon.h
JY5412CoreOODevice.h
JY5412CoreOODIChangeDetectionTask.h
JY5412CoreOODITask.h
JY5412CoreOODOTask.h
JY5412CoreOODOWatchdogTask.h
JY5412CoreOOLog.h
JY5412CoreOOPowerUpStates.h
Generated by doxygen 1.15.0


5412 COO Programming Manual: C:/COO/JY5412CoreOOCommon.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • C:
  • COO
Classes | Namespaces | Macros | Enumerations | Variables
JY5412CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5412CoreOO::JYDriverException
class | JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...

Namespaces

namespace | JY5412Import
namespace | JY5412CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5412CoreOO_API

Enumerations

enum class JY5412CoreOO::JY5412CoreOOPropertyType { JY5412CoreOO::READ_ONLY = 1 , JY5412CoreOO::WRITE_ONLY = 2 , JY5412CoreOO::READ_WRITE = 3 }
enum class JY5412CoreOO::JYErrorCode {
JY5412CoreOO::NoError = 0 , JY5412CoreOO::TimeOut = -10001 , JY5412CoreOO::ErrorParam = -10002 , JY5412CoreOO::IncorrectCallOrder = -10003 ,
JY5412CoreOO::CannotCall = -10004 , JY5412CoreOO::UserBufferError = -10005 , JY5412CoreOO::BufferOverflow = -10006 , JY5412CoreOO::BufferDownflow = -10007 ,
JY5412CoreOO::HardwareResourceReserved = -10008 , JY5412CoreOO::aiIsStart = -10009 , JY5412CoreOO::ErrorParam1 = -10010
}
错误代码的定义 More...
enum class JY5412CoreOO::JYDriverExceptionPublic {
JY5412CoreOO::UnKnown = 0 , JY5412CoreOO::OpenDeviceFailed = -10001 , JY5412CoreOO::CloseDeviceFailed = -10002 , JY5412CoreOO::ResetDeviceFailed = -10003 ,
JY5412CoreOO::GetDevicePropertyFailed = -10004 , JY5412CoreOO::SetDevicePropertyFailed = -10005 , JY5412CoreOO::HardwareResourceIsReserved = -10006 , JY5412CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5412CoreOO::InvalidUserDataBuffer = -10008 , JY5412CoreOO::NoChannelAdded = -10009 , JY5412CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5412CoreOO::CreatTaskFailed = -10100 ,
JY5412CoreOO::StartTaskFailed = -10101 , JY5412CoreOO::StopTaskFailed = -10102 , JY5412CoreOO::TaskHasNotStarted = -10103 , JY5412CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5412CoreOO::ChannelNumberParameterInvalid = -10105 , JY5412CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5412CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5412CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5412CoreOO::SampeleModeParameterInvalid = -10109 , JY5412CoreOO::SampleClockParameterInvalid = -10110 , JY5412CoreOO::SampleRateParameterInvalid = -10111 , JY5412CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5412CoreOO::TriggerParameterInvalid = -10113 , JY5412CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5412CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5412CoreOO::ReadDataFailed = -10016 ,
JY5412CoreOO::ReadDataTimeout = -10017 , JY5412CoreOO::WriteDataFailed = -10018 , JY5412CoreOO::WriteDataTimeout = -10019 , JY5412CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5412CoreOO::BufferDataOverflow = -10021 , JY5412CoreOO::BufferDataDownflow = -10022 , JY5412CoreOO::CheckBufferFailed = -10023 , JY5412CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5412CoreOO::ReadPointInvalid = -10025 , JY5412CoreOO::OnlySupportRecordMode = -10026 , JY5412CoreOO::SendSoftTirggerFailed = -10027 , JY5412CoreOO::TaskTimeout = -10028 ,
JY5412CoreOO::CounterParametersInvalid = -10029 , JY5412CoreOO::WritePointInvalid = -10030 , JY5412CoreOO::SignalExportDestinationInvalid = -10031 , JY5412CoreOO::InvalidParameter = -10033 ,
JY5412CoreOO::ArrayLengthsNotConsistent = -10035
}

Variables

const int | JY5412Import::Floating = 0x0
const int | JY5412Import::PullUp = 0x1
const int | JY5412Import::PullDown = 0x2
const int | JY5412Import::PushPull = 0x0
const int | JY5412Import::OpenDrain = 0x1
const int | JY5412Import::High = 0x0
const int | JY5412Import::Low = 0x1
const int | JY5412Import::Tristate = 0x2
const int | JY5412Import::NoChange = 0x3
const int | JY5412Import::RisingEdge = 0x1
const int | JY5412Import::FallingEdge = 0x2
const int | JY5412Import::BothEdge = 0x0
const int | JY5412Import::CMOS3V3 = 0x0
const int | JY5412Import::CMOS5V0 = 0x1
const int | JY5412Import::ChangeDetectionEvent = 0
const int | JY5412Import::LinesCOS = 0x0
const int | JY5412Import::Timer = 0x1
const int | JY5412Import::EventCounter = 0x2
const int | JY5412Import::LineXOrnLineY = 0x3

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5412CoreOO_API

#define JY5412CoreOO_API


5412 COO Programming Manual: JY5412CoreOO::JYDriverException Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5412CoreOO
  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::JYDriverException Class Reference

#include <JY5412CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (JYErrorCode exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/3]

JY5412CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/3]

JY5412CoreOO::JYDriverException::JYDriverException | ( | JYErrorCode | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [3/3]

JY5412CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5412CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5412CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5412CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOOCommon.h


5412 COO Programming Manual: JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5412CoreOO
  • JY5412CoreOOProperty
Public Member Functions | List of all members
JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5412CoreOOCommon.h>

Public Member Functions

JY5412CoreOOProperty ()
JY5412CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5412CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
~JY5412CoreOOProperty ()
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5412CoreOOPropertyType propertyType>
class JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5412CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5412CoreOOPropertyType propertyType>
JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5412CoreOOProperty ( )

◆ JY5412CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5412CoreOOPropertyType propertyType>
JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5412CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5412CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5412CoreOOPropertyType propertyType>
JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5412CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

◆ ~JY5412CoreOOProperty()

template<typename ContainerClass, typename ValueType, JY5412CoreOOPropertyType propertyType>
JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >::~JY5412CoreOOProperty ( )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5412CoreOOPropertyType propertyType>
JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5412CoreOOPropertyType propertyType>
ValueType JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOOCommon.h


5412 COO Programming Manual: JY5412CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations
JY5412CoreOO Namespace Reference

Classes

class | JYDriverException
class | JY5412CoreOOProperty
属性模板类 More...
class | JY5412CoreOODevice
struct | ChangeDetectionEventInfo
class | ChangeDetectionEventInformation
class | JY5412CoreOODIChangeDetectionTask
class | ChangeDetectionChannel
ChangeDetectionEvent Channel parameter class . More...
class | JY5412CoreOODITask
class | DIChannel
DI Channel parameter class . More...
class | JY5412CoreOODOTask
class | DOChannel
DO Channel parameter class . More...
class | JY5412CoreOODOWatchdogTask
class | WatchdogChannel
WatchdogChannel class. More...
class | JY5412CoreOOLog
class | PortLogicLevelPowerUpStates
The class used to set the default logic level of the power-on state. More...
class | ChannelPowerUpStates
A class for setting the default power-on state of input or output. More...
class | JY5412PowerUpStates
Power-on state configuration. More...
class | Input_PowerUpStates
Input PowerUpStates param. More...
class | Output_PowerUpStates
Output PowerUpStates param. More...

Typedefs

typedef void(* | private_CallbackFunc) (void *hDevice, ChangeDetectionEventInfo *eventInfo, void *callbackData)
typedef void(* | JY5412CoreOO_CallbackFunc) (ChangeDetectionEventInformation *EventInfo)

Enumerations

enum class | JY5412CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYErrorCode {
NoError = 0 , TimeOut = -10001 , ErrorParam = -10002 , IncorrectCallOrder = -10003 ,
CannotCall = -10004 , UserBufferError = -10005 , BufferOverflow = -10006 , BufferDownflow = -10007 ,
HardwareResourceReserved = -10008 , aiIsStart = -10009 , ErrorParam1 = -10010
}
错误代码的定义 More...
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033 ,
ArrayLengthsNotConsistent = -10035
}
enum class | LogicLevel { CMOS3_3V = JY5412Import::CMOS3V3 , CMOS5_0V = JY5412Import::CMOS5V0 }
Push pull. More...
enum class | DITerminal { Floating = JY5412Import::Floating , PullUp = JY5412Import::PullUp , PullDown = JY5412Import::PullDown }
Input Mode. More...
enum class | DOTerminal { PushPull = JY5412Import::PushPull , OpenDrain = JY5412Import::OpenDrain }
DOTerminal. More...
enum class | ChangeDetectionMode { RisingEdge = JY5412Import::RisingEdge , FallingEdge = JY5412Import::FallingEdge , BothEdge = JY5412Import::BothEdge }
ChangeDetectionMode. More...
enum class | WatchdogExpirationState { High = JY5412Import::High , Low = JY5412Import::Low , Tristate = JY5412Import::Tristate , NoChange = JY5412Import::NoChange }
Watchdog expiration state. More...
enum class JY5412CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}
enum class | PowerUpStateMode { Output , Input }
Input Mode. More...

Typedef Documentation

◆ JY5412CoreOO_CallbackFunc

typedef void(* JY5412CoreOO::JY5412CoreOO_CallbackFunc) (ChangeDetectionEventInformation *EventInfo)

◆ private_CallbackFunc

typedef void(* JY5412CoreOO::private_CallbackFunc) (void *hDevice, ChangeDetectionEventInfo *eventInfo, void *callbackData)

Enumeration Type Documentation

◆ ChangeDetectionMode

enum class JY5412CoreOO::ChangeDetectionMode
strong

ChangeDetectionMode.

Enumerator
RisingEdge | Rising edge detection.
FallingEdge | Falling edge detection.
BothEdge | Edge detection.

◆ DITerminal

enum class JY5412CoreOO::DITerminal
strong

Input Mode.

Enumerator
Floating | Not enable pull-up and pull-down.
PullUp | PullUp.
PullDown | PullDown.

◆ DOTerminal

enum class JY5412CoreOO::DOTerminal
strong

DOTerminal.

Enumerator
PushPull | Push pull.
OpenDrain | Open drain.

◆ JY5412CoreOOLogLevel

enum class JY5412CoreOO::JY5412CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5412CoreOOPropertyType

enum class JY5412CoreOO::JY5412CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5412CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | Invaild parameter.
ArrayLengthsNotConsistent | Array lengths are not consistent.

◆ JYErrorCode

enum class JY5412CoreOO::JYErrorCode
strong

错误代码的定义

Enumerator
NoError | 无错误
TimeOut | 超时
ErrorParam | 参数错误
IncorrectCallOrder | 调用顺序不正确
CannotCall | 当前配置不能调用该方法
UserBufferError | 用户缓冲区错误
BufferOverflow | 缓冲区溢出
BufferDownflow | 缓冲区下溢出
HardwareResourceReserved | 硬件资源已被占用
aiIsStart | AI已经启动，不用添加通道
ErrorParam1 | 输入幅值范围不正确,范围最大值和最小值

◆ LogicLevel

enum class JY5412CoreOO::LogicLevel
strong

Push pull.

Enumerator
CMOS3_3V | Logic level 3.3V.
CMOS5_0V | Logic level 5.0V.

◆ PowerUpStateMode

enum class JY5412CoreOO::PowerUpStateMode
strong

Input Mode.

Enumerator
Output | OutPut.
Input | Input.

◆ WatchdogExpirationState

enum class JY5412CoreOO::WatchdogExpirationState
strong

Watchdog expiration state.

Enumerator
High | High logic.
Low | Low logic.
Tristate | High-impedance.
NoChange | No change the status.. .


5412 COO Programming Manual: JY5412Import Namespace Reference

  • Namespace List
  • Namespace Members
Variables
JY5412Import Namespace Reference

Variables

const int | Floating = 0x0
const int | PullUp = 0x1
const int | PullDown = 0x2
const int | PushPull = 0x0
const int | OpenDrain = 0x1
const int | High = 0x0
const int | Low = 0x1
const int | Tristate = 0x2
const int | NoChange = 0x3
const int | RisingEdge = 0x1
const int | FallingEdge = 0x2
const int | BothEdge = 0x0
const int | CMOS3V3 = 0x0
const int | CMOS5V0 = 0x1
const int | ChangeDetectionEvent = 0
const int | LinesCOS = 0x0
const int | Timer = 0x1
const int | EventCounter = 0x2
const int | LineXOrnLineY = 0x3

Variable Documentation

◆ BothEdge

const int JY5412Import::BothEdge = 0x0

◆ ChangeDetectionEvent

const int JY5412Import::ChangeDetectionEvent = 0

◆ CMOS3V3

const int JY5412Import::CMOS3V3 = 0x0

◆ CMOS5V0

const int JY5412Import::CMOS5V0 = 0x1

◆ EventCounter

const int JY5412Import::EventCounter = 0x2

◆ FallingEdge

const int JY5412Import::FallingEdge = 0x2

◆ Floating

const int JY5412Import::Floating = 0x0

◆ High

const int JY5412Import::High = 0x0

◆ LinesCOS

const int JY5412Import::LinesCOS = 0x0

◆ LineXOrnLineY

const int JY5412Import::LineXOrnLineY = 0x3

◆ Low

const int JY5412Import::Low = 0x1

◆ NoChange

const int JY5412Import::NoChange = 0x3

◆ OpenDrain

const int JY5412Import::OpenDrain = 0x1

◆ PullDown

const int JY5412Import::PullDown = 0x2

◆ PullUp

const int JY5412Import::PullUp = 0x1

◆ PushPull

const int JY5412Import::PushPull = 0x0

◆ RisingEdge

const int JY5412Import::RisingEdge = 0x1

◆ Timer

const int JY5412Import::Timer = 0x1

◆ Tristate

const int JY5412Import::Tristate = 0x2


5412 COO Programming Manual: C:/COO/JY5412CoreOODevice.h File Reference

  • File List
  • File Members
  • C:
  • COO
Classes | Namespaces | Enumerations
JY5412CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY5412CoreOOCommon.h"
#include "JY5412CoreOOPowerUpStates.h"

Classes

class JY5412CoreOO::JY5412CoreOODevice

Namespaces

namespace JY5412CoreOO

Enumerations

enum class | JY5412CoreOO::LogicLevel { JY5412CoreOO::CMOS3_3V = JY5412Import::CMOS3V3 , JY5412CoreOO::CMOS5_0V = JY5412Import::CMOS5V0 }
Push pull. More...
enum class | JY5412CoreOO::DITerminal { JY5412CoreOO::Floating = JY5412Import::Floating , JY5412CoreOO::PullUp = JY5412Import::PullUp , JY5412CoreOO::PullDown = JY5412Import::PullDown }
Input Mode. More...
enum class | JY5412CoreOO::DOTerminal { JY5412CoreOO::PushPull = JY5412Import::PushPull , JY5412CoreOO::OpenDrain = JY5412Import::OpenDrain }
DOTerminal. More...


5412 COO Programming Manual: JY5412CoreOO::JY5412CoreOODevice Class Reference

  • JY5412CoreOODevice
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | List of all members
JY5412CoreOO::JY5412CoreOODevice Class Reference

#include <JY5412CoreOODevice.h>

Public Member Functions

void | SetLogicLevel (int portID, LogicLevel logiclevel)
Set the logic level.
void | SetLogicLevel (std::vector< int > &portID, std::vector< LogicLevel > &logiclevel)
Set the logic level.
void | SetMinPulseWidth (int portID, int minePulseWidth)
Set the filtering parameters for the specified line.
void | SetMinPulseWidth (std::vector< int > &portID, std::vector< int > &minePulseWidth)
Set the filtering parameters for the specified line.
void | SetPowerUpStates (JY5412PowerUpStates *powerUpStates)
Set the default power-on state.
void | SetPowerUpStates (JY5412PowerUpStates &powerUpStates)
Set the default power-on state.
void | GetPowerUpStates (JY5412PowerUpStates &powerUpStates)
Obtain the power-on status configuration.
void | Release ()
Turn off the AD device, disable transmission, and release resources.

Static Public Member Functions

static JY5412CoreOODevice * | GetInstance (int cardNum)
static JY5412CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

JY5412CoreOOProperty< JY5412CoreOODevice, void *, JY5412CoreOOPropertyType::READ_ONLY > Handle

Static Public Attributes

static const int | NumOfLinesPerPort = 24
static const int | NumberOfPorts = 4

Member Function Documentation

◆ GetInstance() [1/2]

JY5412CoreOODevice * JY5412CoreOO::JY5412CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

JY5412CoreOODevice * JY5412CoreOO::JY5412CoreOODevice::GetInstance ( std::string aliasName )
static

◆ GetPowerUpStates()

void JY5412CoreOO::JY5412CoreOODevice::GetPowerUpStates ( JY5412PowerUpStates & powerUpStates )

Obtain the power-on status configuration.

Parameters
powerUpStates
Exceptions
JYDriverException

◆ Release()

void JY5412CoreOO::JY5412CoreOODevice::Release ( )

Turn off the AD device, disable transmission, and release resources.

This function is automatically executed in the destructor of the class

◆ SetLogicLevel() [1/2]

void JY5412CoreOO::JY5412CoreOODevice::SetLogicLevel | ( | int | portID,
 |  | LogicLevel | logiclevel )

Set the logic level.

Each port can be configured independently. Options are 3.3V and 5V.

Parameters
portID | port number to be set.
logiclevel | logic level

◆ SetLogicLevel() [2/2]

void JY5412CoreOO::JY5412CoreOODevice::SetLogicLevel | ( | std::vector< int > & | portID,
 |  | std::vector< LogicLevel > & | logiclevel )

Set the logic level.

Each port can be configured independently. Options are 3.3V and 5V.

Parameters
portID | an array of port numbers to be set.
logiclevel | an array of logic level to be set.

◆ SetMinPulseWidth() [1/2]

void JY5412CoreOO::JY5412CoreOODevice::SetMinPulseWidth | ( | int | portID,
 |  | int | minePulseWidth )

Set the filtering parameters for the specified line.

The minPulseWidth parameter is shared by each port.

Parameters
portID | an array of port numbers to be set.
minePulseWidth | an array of mine PulseWidth to be set.Unit: nanoseconds, range: 100ns to 200ms
Exceptions
JYDriverException

◆ SetMinPulseWidth() [2/2]

void JY5412CoreOO::JY5412CoreOODevice::SetMinPulseWidth | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | minePulseWidth )

Set the filtering parameters for the specified line.

The minPulseWidth parameter is shared by each port.

Parameters
portID | an array of port numbers to be set.
minePulseWidth | an array of mine PulseWidth to be set.Unit: nanoseconds, range: 100ns to 200ms
Exceptions
JYDriverException

◆ SetPowerUpStates() [1/2]

void JY5412CoreOO::JY5412CoreOODevice::SetPowerUpStates ( JY5412PowerUpStates & powerUpStates )

Set the default power-on state.

Parameters
powerUpStates Set the parameters for the default power-on state
Exceptions
JYDriverException

◆ SetPowerUpStates() [2/2]

void JY5412CoreOO::JY5412CoreOODevice::SetPowerUpStates ( JY5412PowerUpStates * powerUpStates )

Set the default power-on state.

Parameters
powerUpStates Set the parameters for the default power-on state
Exceptions
JYDriverException

Member Data Documentation

◆ Handle

JY5412CoreOOProperty<JY5412CoreOODevice, void*, JY5412CoreOOPropertyType::READ_ONLY> JY5412CoreOO::JY5412CoreOODevice::Handle

◆ NumberOfPorts

const int JY5412CoreOO::JY5412CoreOODevice::NumberOfPorts = 4
static

◆ NumOfLinesPerPort

const int JY5412CoreOO::JY5412CoreOODevice::NumOfLinesPerPort = 24
static
The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODevice.h


5412 COO Programming Manual: C:/COO/JY5412CoreOODIChangeDetectionTask.h File Reference

  • File List
  • File Members
  • C:
  • COO
Classes | Namespaces | Typedefs | Enumerations
JY5412CoreOODIChangeDetectionTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5412CoreOOCommon.h"
#include "JY5412CoreOODevice.h"

Classes

struct | JY5412CoreOO::ChangeDetectionEventInfo
class | JY5412CoreOO::ChangeDetectionEventInformation
class | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask
class | JY5412CoreOO::ChangeDetectionChannel
ChangeDetectionEvent Channel parameter class . More...

Namespaces

namespace JY5412CoreOO

Typedefs

typedef void(* | JY5412CoreOO::private_CallbackFunc) (void *hDevice, ChangeDetectionEventInfo *eventInfo, void *callbackData)
typedef void(* | JY5412CoreOO::JY5412CoreOO_CallbackFunc) (ChangeDetectionEventInformation *EventInfo)

Enumerations

enum class JY5412CoreOO::ChangeDetectionMode { JY5412CoreOO::RisingEdge = JY5412Import::RisingEdge , JY5412CoreOO::FallingEdge = JY5412Import::FallingEdge , JY5412CoreOO::BothEdge = JY5412Import::BothEdge }
ChangeDetectionMode. More...


5412 COO Programming Manual: JY5412CoreOO::ChangeDetectionEventInfo Struct Reference

  • ChangeDetectionEventInfo
Public Attributes | List of all members
JY5412CoreOO::ChangeDetectionEventInfo Struct Reference

#include <JY5412CoreOODIChangeDetectionTask.h>

Public Attributes

bool | lineChanged [JY5412CoreOODevice::NumberOfPorts *JY5412CoreOODevice::NumOfLinesPerPort]
int | lineLevel [JY5412CoreOODevice::NumberOfPorts *JY5412CoreOODevice::NumOfLinesPerPort]

Member Data Documentation

◆ lineChanged

bool JY5412CoreOO::ChangeDetectionEventInfo::lineChanged[JY5412CoreOODevice::NumberOfPorts *JY5412CoreOODevice::NumOfLinesPerPort]

◆ lineLevel

int JY5412CoreOO::ChangeDetectionEventInfo::lineLevel[JY5412CoreOODevice::NumberOfPorts *JY5412CoreOODevice::NumOfLinesPerPort]
The documentation for this struct was generated from the following file:
  • C:/COO/JY5412CoreOODIChangeDetectionTask.h


5412 COO Programming Manual: JY5412CoreOO::ChangeDetectionEventInformation Class Reference

  • ChangeDetectionEventInformation
Public Attributes | Friends | List of all members
JY5412CoreOO::ChangeDetectionEventInformation Class Reference

#include <JY5412CoreOODIChangeDetectionTask.h>

Public Attributes

void * | UserData
user data
std::vector< int > | PortID
PortID.
std::vector< int > | LineID
LineID.
std::vector< bool > | Level
The level that triggers the interruption can only be checked after the interruption occurs.

Friends

class JY5412CoreOODIChangeDetectionTask

Friends And Related Symbol Documentation

◆ JY5412CoreOODIChangeDetectionTask

friend class JY5412CoreOODIChangeDetectionTask
friend

Member Data Documentation

◆ Level

std::vector<bool> JY5412CoreOO::ChangeDetectionEventInformation::Level

The level that triggers the interruption can only be checked after the interruption occurs.

◆ LineID

std::vector<int> JY5412CoreOO::ChangeDetectionEventInformation::LineID

LineID.

◆ PortID

std::vector<int> JY5412CoreOO::ChangeDetectionEventInformation::PortID

PortID.

◆ UserData

void* JY5412CoreOO::ChangeDetectionEventInformation::UserData

user data

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODIChangeDetectionTask.h


5412 COO Programming Manual: JY5412CoreOO::JY5412CoreOODIChangeDetectionTask Class Reference

  • JY5412CoreOODIChangeDetectionTask
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
JY5412CoreOO::JY5412CoreOODIChangeDetectionTask Class Reference

#include <JY5412CoreOODIChangeDetectionTask.h>

Public Member Functions

JY5412CoreOODIChangeDetectionTask (int slotNum)
JY5412CoreOODIChangeDetectionTask (std::string &boardName)
~JY5412CoreOODIChangeDetectionTask ()
void | AddChannel (int portID, int lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false)
add single channel
void | AddChannel (int portID, std::vector< int > &lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int portID, std::vector< int > &lineID, std::vector< ChangeDetectionMode > &changeDetectionMode, std::vector< DITerminal > &terminal, std::vector< bool > &enableDigitalFilter)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, std::vector< ChangeDetectionMode > &changeDetectionMode, std::vector< DITerminal > &terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, std::vector< ChangeDetectionMode > &changeDetectionMode, std::vector< DITerminal > &terminal, std::vector< bool > &enableDigitalFilter)
Add multiple channels.
void | RemoveChannel (int portID, int lineID)
Delete the specified line number .If it is -1, delete all lines.
void | RemoveChannel (std::vector< int > &portID, std::vector< int > &lineID)
Delete the specified line number .
void | ReadSinglePoint (bool &readValues, int portID, int lineID)
Specify the line reads the latest line.Available when Type is DITerminal.Single.
void | ReadSinglePoint (bool *readValues)
Specify the line reads the latest line.Available when Type is DITerminal.Single.
void | ReadSinglePoint (std::vector< bool > &readValues)
Specify the line reads the latest line.Available when Type is DITerminal.Single.
void | Start ()
Start task.
void | Stop ()
Stop task.

Public Attributes

std::vector< ChangeDetectionChannel * > | Channels
Vector of DI channels.
JY5412CoreOODevice * Device
Device.
void * | UserData
user data

Static Public Attributes

static JY5412CoreOO_CallbackFunc ChangeDetected
Change detection event.

Constructor & Destructor Documentation

◆ JY5412CoreOODIChangeDetectionTask() [1/2]

JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::JY5412CoreOODIChangeDetectionTask ( int slotNum )

◆ JY5412CoreOODIChangeDetectionTask() [2/2]

JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::JY5412CoreOODIChangeDetectionTask ( std::string & boardName )

◆ ~JY5412CoreOODIChangeDetectionTask()

JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::~JY5412CoreOODIChangeDetectionTask ( )

Member Function Documentation

◆ AddChannel() [1/5]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::AddChannel | ( | int | portID,
 |  | int | lineID,
 |  | ChangeDetectionMode | changeDetectionMode,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

add single channel

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
changeDetectionMode | ChangeDetection mode.
terminal | terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [2/5]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | ChangeDetectionMode | changeDetectionMode,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines(0~23).
changeDetectionMode | ChangeDetection mode.
terminal | terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [3/5]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< ChangeDetectionMode > & | changeDetectionMode,
 |  | std::vector< DITerminal > & | terminal,
 |  | std::vector< bool > & | enableDigitalFilter )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines(0~23).
changeDetectionMode
terminal | an array of terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [4/5]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< ChangeDetectionMode > & | changeDetectionMode,
 |  | std::vector< DITerminal > & | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
changeDetectionMode
terminal | an array of terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [5/5]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< ChangeDetectionMode > & | changeDetectionMode,
 |  | std::vector< DITerminal > & | terminal,
 |  | std::vector< bool > & | enableDigitalFilter )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
changeDetectionMode
terminal | an array of terminal configuration.
enableDigitalFilter | Enable digital filtering.

◆ ReadSinglePoint() [1/3]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::ReadSinglePoint | ( | bool & | readValues,
 |  | int | portID,
 |  | int | lineID )

Specify the line reads the latest line.Available when Type is DITerminal.Single.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ ReadSinglePoint() [2/3]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::ReadSinglePoint ( bool * readValues )

Specify the line reads the latest line.Available when Type is DITerminal.Single.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ ReadSinglePoint() [3/3]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::ReadSinglePoint ( std::vector< bool > & readValues )

Specify the line reads the latest line.Available when Type is DITerminal.Single.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ RemoveChannel() [1/2]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::RemoveChannel | ( | int | portID,
 |  | int | lineID )

Delete the specified line number .If it is -1, delete all lines.

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ RemoveChannel() [2/2]

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::RemoveChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID )

Delete the specified line number .

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ Start()

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::Start ( )

Start task.

Exceptions
JYDriverException

◆ Stop()

void JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::Stop ( )

Stop task.

Exceptions
JYDriverException

Member Data Documentation

◆ ChangeDetected

JY5412CoreOO_CallbackFunc JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::ChangeDetected
static

Change detection event.

◆ Channels

std::vector<ChangeDetectionChannel*> JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::Channels

Vector of DI channels.

◆ Device

JY5412CoreOODevice* JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::Device

Device.

◆ UserData

void* JY5412CoreOO::JY5412CoreOODIChangeDetectionTask::UserData

user data

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODIChangeDetectionTask.h


5412 COO Programming Manual: JY5412CoreOO::ChangeDetectionChannel Class Reference

  • ChangeDetectionChannel
Public Attributes | List of all members
JY5412CoreOO::ChangeDetectionChannel Class Reference

ChangeDetectionEvent Channel parameter class . More...

#include <JY5412CoreOODIChangeDetectionTask.h>

Public Attributes

int | PortID
PortID.
int | LineID
LineID.
ChangeDetectionMode ChangeDetection_Mode
Change detection mode.
DITerminal Terminal
DI Terminal.
bool | EnableDigitalFilter
Enable digital filter.

Detailed Description

ChangeDetectionEvent Channel parameter class .

Member Data Documentation

◆ ChangeDetection_Mode

ChangeDetectionMode JY5412CoreOO::ChangeDetectionChannel::ChangeDetection_Mode

Change detection mode.

◆ EnableDigitalFilter

bool JY5412CoreOO::ChangeDetectionChannel::EnableDigitalFilter

Enable digital filter.

◆ LineID

int JY5412CoreOO::ChangeDetectionChannel::LineID

LineID.

◆ PortID

int JY5412CoreOO::ChangeDetectionChannel::PortID

PortID.

◆ Terminal

DITerminal JY5412CoreOO::ChangeDetectionChannel::Terminal

DI Terminal.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODIChangeDetectionTask.h


5412 COO Programming Manual: C:/COO/JY5412CoreOODITask.h File Reference

  • File List
  • File Members
  • C:
  • COO
Classes | Namespaces
JY5412CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5412CoreOOCommon.h"
#include "JY5412CoreOODevice.h"

Classes

class | JY5412CoreOO::JY5412CoreOODITask
class | JY5412CoreOO::DIChannel
DI Channel parameter class . More...

Namespaces

namespace JY5412CoreOO


5412 COO Programming Manual: JY5412CoreOO::JY5412CoreOODITask Class Reference

  • JY5412CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::JY5412CoreOODITask Class Reference

#include <JY5412CoreOODITask.h>

Public Member Functions

JY5412CoreOODITask (int slotNum)
JY5412CoreOODITask (std::string &boardName)
~JY5412CoreOODITask ()
void | AddChannel (int portID, int lineID, DITerminal terminal, bool enableDigitalFilter=false)
Add single channel.
void | AddChannel (int portID, std::vector< int > &lineID, DITerminal terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (int portID, std::vector< int > &lineID, std::vector< DITerminal > &terminal, std::vector< bool > &enableDigitalFilter)
Add multiple channels.
void | AddChannel (int portID, std::vector< int > &lineID, std::vector< DITerminal > &terminal)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, std::vector< DITerminal > &terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, std::vector< DITerminal > &terminal, std::vector< bool > &enableDigitalFilter)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, DITerminal terminal, bool enableDigitalFilter=false)
Add multiple channels.
void | RemoveChannel (int portID, int lineID)
Delete the specified line number .If it is -1, delete all lines.
void | RemoveChannel (std::vector< int > &portID, std::vector< int > &lineID)
Delete the specified line number .
void | ReadSinglePoint (bool &readValues, int portID, int lineID)
Specify the line reads the latest line.Available when Type is DITerminal.Single.
void | ReadSinglePoint (bool *readValues)
Specify the line reads the latest line.Available when Type is DITerminal.Single.
void | ReadSinglePoint (std::vector< bool > &readValues)
Specify the line reads the latest line.Available when Type is DITerminal.Single.

Public Attributes

std::vector< DIChannel * > Channels
Vector of DI channels.
JY5412CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5412CoreOODITask() [1/2]

JY5412CoreOO::JY5412CoreOODITask::JY5412CoreOODITask ( int slotNum )

◆ JY5412CoreOODITask() [2/2]

JY5412CoreOO::JY5412CoreOODITask::JY5412CoreOODITask ( std::string & boardName )

◆ ~JY5412CoreOODITask()

JY5412CoreOO::JY5412CoreOODITask::~JY5412CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/7]

void JY5412CoreOO::JY5412CoreOODITask::AddChannel | ( | int | portID,
 |  | int | lineID,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add single channel.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
terminal | input terminal.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [2/7]

void JY5412CoreOO::JY5412CoreOODITask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
terminal | input terminal.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [3/7]

void JY5412CoreOO::JY5412CoreOODITask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< DITerminal > & | terminal )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
terminal | an array addition input terminal.

◆ AddChannel() [4/7]

void JY5412CoreOO::JY5412CoreOODITask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< DITerminal > & | terminal,
 |  | std::vector< bool > & | enableDigitalFilter )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
terminal | an array addition input terminal.
enableDigitalFilter | an array of enable digital filtering.

◆ AddChannel() [5/7]

void JY5412CoreOO::JY5412CoreOODITask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | DITerminal | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | input terminal.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [6/7]

void JY5412CoreOO::JY5412CoreOODITask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< DITerminal > & | terminal,
 |  | bool | enableDigitalFilter = false )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | an array addition input terminal.
enableDigitalFilter | Enable digital filtering.

◆ AddChannel() [7/7]

void JY5412CoreOO::JY5412CoreOODITask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< DITerminal > & | terminal,
 |  | std::vector< bool > & | enableDigitalFilter )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
terminal | an array addition input terminal.
enableDigitalFilter | an array of enable digital filtering.

◆ ReadSinglePoint() [1/3]

void JY5412CoreOO::JY5412CoreOODITask::ReadSinglePoint | ( | bool & | readValues,
 |  | int | portID,
 |  | int | lineID )

Specify the line reads the latest line.Available when Type is DITerminal.Single.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ ReadSinglePoint() [2/3]

void JY5412CoreOO::JY5412CoreOODITask::ReadSinglePoint ( bool * readValues )

Specify the line reads the latest line.Available when Type is DITerminal.Single.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ ReadSinglePoint() [3/3]

void JY5412CoreOO::JY5412CoreOODITask::ReadSinglePoint ( std::vector< bool > & readValues )

Specify the line reads the latest line.Available when Type is DITerminal.Single.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ RemoveChannel() [1/2]

void JY5412CoreOO::JY5412CoreOODITask::RemoveChannel | ( | int | portID,
 |  | int | lineID )

Delete the specified line number .If it is -1, delete all lines.

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ RemoveChannel() [2/2]

void JY5412CoreOO::JY5412CoreOODITask::RemoveChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID )

Delete the specified line number .

Parameters
portID | port number to be delete.
lineID | line number to be delete.

Member Data Documentation

◆ Channels

std::vector<DIChannel*> JY5412CoreOO::JY5412CoreOODITask::Channels

Vector of DI channels.

◆ Device

JY5412CoreOODevice* JY5412CoreOO::JY5412CoreOODITask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODITask.h


5412 COO Programming Manual: JY5412CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY5412CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY5412CoreOODITask.h>

Public Attributes

int | PortID
PortID.
int | LineID
LineID.
DITerminal Terminal
DI Terminal.
bool | EnableDigitalFilter
Enable digital filter.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ EnableDigitalFilter

bool JY5412CoreOO::DIChannel::EnableDigitalFilter

Enable digital filter.

◆ LineID

int JY5412CoreOO::DIChannel::LineID

LineID.

◆ PortID

int JY5412CoreOO::DIChannel::PortID

PortID.

◆ Terminal

DITerminal JY5412CoreOO::DIChannel::Terminal

DI Terminal.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODITask.h


5412 COO Programming Manual: C:/COO/JY5412CoreOODOTask.h File Reference

  • File List
  • File Members
  • C:
  • COO
Classes | Namespaces
JY5412CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5412CoreOOCommon.h"
#include "JY5412CoreOODevice.h"

Classes

class | JY5412CoreOO::JY5412CoreOODOTask
class | JY5412CoreOO::DOChannel
DO Channel parameter class . More...

Namespaces

namespace JY5412CoreOO


5412 COO Programming Manual: JY5412CoreOO::JY5412CoreOODOTask Class Reference

  • JY5412CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::JY5412CoreOODOTask Class Reference

#include <JY5412CoreOODOTask.h>

Public Member Functions

JY5412CoreOODOTask (int slotNum)
JY5412CoreOODOTask (std::string &boardName)
~JY5412CoreOODOTask ()
void | AddChannel (int portID, int lineID, DOTerminal mode)
add single channel
void | AddChannel (int portID, std::vector< int > &lineID, DOTerminal mode)
Add multiple channels.
void | AddChannel (int portID, std::vector< int > &lineID, std::vector< DOTerminal > &mode)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, std::vector< DOTerminal > &mode)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, int lineID, DOTerminal mode)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, int lineID, std::vector< DOTerminal > &mode)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, DOTerminal mode)
Add multiple channels.
void | RemoveChannel (int portID, int lineID)
Delete the specified line number .If it is -1, delete all lines.
void | RemoveChannel (std::vector< int > &portID, std::vector< int > &lineID)
Delete the specified line number .
void | WriteSinglePoint (bool writeValue, int portID, int lineID)
Write one sample to the specified line in register />.
void | WriteSinglePoint (bool *writeValues)
write one sample to all lines in register .
void | WriteSinglePoint (std::vector< bool > &writeValues)
write one sample to all lines in register .

Public Attributes

std::vector< DOChannel * > Channels
Vector of DO channels.
JY5412CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5412CoreOODOTask() [1/2]

JY5412CoreOO::JY5412CoreOODOTask::JY5412CoreOODOTask ( int slotNum )

◆ JY5412CoreOODOTask() [2/2]

JY5412CoreOO::JY5412CoreOODOTask::JY5412CoreOODOTask ( std::string & boardName )

◆ ~JY5412CoreOODOTask()

JY5412CoreOO::JY5412CoreOODOTask::~JY5412CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/7]

void JY5412CoreOO::JY5412CoreOODOTask::AddChannel | ( | int | portID,
 |  | int | lineID,
 |  | DOTerminal | mode )

add single channel

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
mode | output mode.

◆ AddChannel() [2/7]

void JY5412CoreOO::JY5412CoreOODOTask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | DOTerminal | mode )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
mode | output mode.

◆ AddChannel() [3/7]

void JY5412CoreOO::JY5412CoreOODOTask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< DOTerminal > & | mode )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
mode | an array addition output mode.

◆ AddChannel() [4/7]

void JY5412CoreOO::JY5412CoreOODOTask::AddChannel | ( | std::vector< int > & | portID,
 |  | int | lineID,
 |  | DOTerminal | mode )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
mode | output mode.

◆ AddChannel() [5/7]

void JY5412CoreOO::JY5412CoreOODOTask::AddChannel | ( | std::vector< int > & | portID,
 |  | int | lineID,
 |  | std::vector< DOTerminal > & | mode )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
mode | an array addition output mode.

◆ AddChannel() [6/7]

void JY5412CoreOO::JY5412CoreOODOTask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | DOTerminal | mode )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
mode | output mode.

◆ AddChannel() [7/7]

void JY5412CoreOO::JY5412CoreOODOTask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< DOTerminal > & | mode )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
mode | an array addition output mode.

◆ RemoveChannel() [1/2]

void JY5412CoreOO::JY5412CoreOODOTask::RemoveChannel | ( | int | portID,
 |  | int | lineID )

Delete the specified line number .If it is -1, delete all lines.

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ RemoveChannel() [2/2]

void JY5412CoreOO::JY5412CoreOODOTask::RemoveChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID )

Delete the specified line number .

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ WriteSinglePoint() [1/3]

void JY5412CoreOO::JY5412CoreOODOTask::WriteSinglePoint ( bool * writeValues )

write one sample to all lines in register .

" /> <param name="writeValues">write Values.Buffer size >= number of lines。

◆ WriteSinglePoint() [2/3]

void JY5412CoreOO::JY5412CoreOODOTask::WriteSinglePoint | ( | bool | writeValue,
 |  | int | portID,
 |  | int | lineID )

Write one sample to the specified line in register />.

Parameters
writeValue | Write value.
portID | Specified port.
lineID | Specified line.

◆ WriteSinglePoint() [3/3]

void JY5412CoreOO::JY5412CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

write one sample to all lines in register .

" /> <param name="writeValues">write Values.Buffer size >= number of lines。

Member Data Documentation

◆ Channels

std::vector<DOChannel*> JY5412CoreOO::JY5412CoreOODOTask::Channels

Vector of DO channels.

◆ Device

JY5412CoreOODevice* JY5412CoreOO::JY5412CoreOODOTask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODOTask.h


5412 COO Programming Manual: JY5412CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY5412CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY5412CoreOODOTask.h>

Public Attributes

int | PortID
PortID.
int | LineID
LineID.
DOTerminal Mode
DO Mode.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ LineID

int JY5412CoreOO::DOChannel::LineID

LineID.

◆ Mode

DOTerminal JY5412CoreOO::DOChannel::Mode

DO Mode.

◆ PortID

int JY5412CoreOO::DOChannel::PortID

PortID.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODOTask.h


5412 COO Programming Manual: C:/COO/JY5412CoreOODOWatchdogTask.h File Reference

  • File List
  • File Members
  • C:
  • COO
Classes | Namespaces | Enumerations
JY5412CoreOODOWatchdogTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5412CoreOOCommon.h"
#include "JY5412CoreOODevice.h"

Classes

class | JY5412CoreOO::JY5412CoreOODOWatchdogTask
class | JY5412CoreOO::WatchdogChannel
WatchdogChannel class. More...

Namespaces

namespace JY5412CoreOO

Enumerations

enum class JY5412CoreOO::WatchdogExpirationState { JY5412CoreOO::High = JY5412Import::High , JY5412CoreOO::Low = JY5412Import::Low , JY5412CoreOO::Tristate = JY5412Import::Tristate , JY5412CoreOO::NoChange = JY5412Import::NoChange }
Watchdog expiration state. More...


5412 COO Programming Manual: JY5412CoreOO::JY5412CoreOODOWatchdogTask Class Reference

  • JY5412CoreOODOWatchdogTask
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::JY5412CoreOODOWatchdogTask Class Reference

#include <JY5412CoreOODOWatchdogTask.h>

Public Member Functions

JY5412CoreOODOWatchdogTask (int slotNum)
JY5412CoreOODOWatchdogTask (std::string &boardName)
~JY5412CoreOODOWatchdogTask ()
void | AddChannel (int portID, int lineID, WatchdogExpirationState expirationState)
add single channel
void | AddChannel (int portID, std::vector< int > &lineID, WatchdogExpirationState expirationState)
Add multiple channels.
void | AddChannel (int portID, std::vector< int > &lineID, std::vector< WatchdogExpirationState > &expirationState)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, std::vector< WatchdogExpirationState > &expirationState)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, int lineID, WatchdogExpirationState expirationState)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, int lineID, std::vector< WatchdogExpirationState > &expirationState)
Add multiple channels.
void | AddChannel (std::vector< int > &portID, std::vector< int > &lineID, WatchdogExpirationState expirationState)
Add multiple channels.
void | RemoveChannel (int portID, int lineID)
Delete the specified line number .If it is -1, delete all lines.
void | RemoveChannel (std::vector< int > &portID, std::vector< int > &lineID)
Delete the specified line number .
void | Start ()
Run the watchdog task.
void | Stop ()
Stop the watchdog task.
void | Commit ()
After modifying the expiration status and timeout time during the operation, submit the configuration.
void | ClearExpiration ()
Clear the locked state of the timeout watchdog task.
void | ResetTimer ()
Resetting the watchdog task is equivalent to feeding the dog.

Public Attributes

std::vector< WatchdogChannel * > | Channels
Vector of DO channels.
double | Timeout
Timeout time, unit: seconds.
JY5412CoreOOProperty< JY5412CoreOODOWatchdogTask, bool, JY5412CoreOOPropertyType::READ_ONLY > | Expired
Check to see if the watchdog has expired.
JY5412CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5412CoreOODOWatchdogTask() [1/2]

JY5412CoreOO::JY5412CoreOODOWatchdogTask::JY5412CoreOODOWatchdogTask ( int slotNum )

◆ JY5412CoreOODOWatchdogTask() [2/2]

JY5412CoreOO::JY5412CoreOODOWatchdogTask::JY5412CoreOODOWatchdogTask ( std::string & boardName )

◆ ~JY5412CoreOODOWatchdogTask()

JY5412CoreOO::JY5412CoreOODOWatchdogTask::~JY5412CoreOODOWatchdogTask ( )

Member Function Documentation

◆ AddChannel() [1/7]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::AddChannel | ( | int | portID,
 |  | int | lineID,
 |  | WatchdogExpirationState | expirationState )

add single channel

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
expirationState | Expiration state.

◆ AddChannel() [2/7]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< WatchdogExpirationState > & | expirationState )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
expirationState | an array addition output expirationState.

◆ AddChannel() [3/7]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::AddChannel | ( | int | portID,
 |  | std::vector< int > & | lineID,
 |  | WatchdogExpirationState | expirationState )

Add multiple channels.

Parameters
portID | port number to be added.If portID is equal to -1, then add all the corresponding Lines for the PortID.
lineID | an array of line numbers of added lines.
expirationState | output expirationState.

◆ AddChannel() [4/7]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::AddChannel | ( | std::vector< int > & | portID,
 |  | int | lineID,
 |  | std::vector< WatchdogExpirationState > & | expirationState )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
expirationState | an array addition output expirationState.

◆ AddChannel() [5/7]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::AddChannel | ( | std::vector< int > & | portID,
 |  | int | lineID,
 |  | WatchdogExpirationState | expirationState )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | lineID number to be added.If lineID is equal to -1, then add all the corresponding Line for the PortID.
expirationState | output expirationState.

◆ AddChannel() [6/7]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | std::vector< WatchdogExpirationState > & | expirationState )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
expirationState | an array addition output expirationState.

◆ AddChannel() [7/7]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::AddChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID,
 |  | WatchdogExpirationState | expirationState )

Add multiple channels.

Parameters
portID | an array of port numbers of added ports.
lineID | an array of line numbers of added lines.
expirationState | output expirationState.

◆ ClearExpiration()

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::ClearExpiration ( )

Clear the locked state of the timeout watchdog task.

Exceptions
JYDriverException

◆ Commit()

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::Commit ( )

After modifying the expiration status and timeout time during the operation, submit the configuration.

Exceptions
JYDriverException

◆ RemoveChannel() [1/2]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::RemoveChannel | ( | int | portID,
 |  | int | lineID )

Delete the specified line number .If it is -1, delete all lines.

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ RemoveChannel() [2/2]

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::RemoveChannel | ( | std::vector< int > & | portID,
 |  | std::vector< int > & | lineID )

Delete the specified line number .

Parameters
portID | port number to be delete.
lineID | line number to be delete.

◆ ResetTimer()

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::ResetTimer ( )

Resetting the watchdog task is equivalent to feeding the dog.

◆ Start()

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::Start ( )

Run the watchdog task.

◆ Stop()

void JY5412CoreOO::JY5412CoreOODOWatchdogTask::Stop ( )

Stop the watchdog task.

Member Data Documentation

◆ Channels

std::vector<WatchdogChannel*> JY5412CoreOO::JY5412CoreOODOWatchdogTask::Channels

Vector of DO channels.

◆ Device

JY5412CoreOODevice* JY5412CoreOO::JY5412CoreOODOWatchdogTask::Device

Device.

◆ Expired

JY5412CoreOOProperty<JY5412CoreOODOWatchdogTask, bool, JY5412CoreOOPropertyType::READ_ONLY> JY5412CoreOO::JY5412CoreOODOWatchdogTask::Expired

Check to see if the watchdog has expired.

◆ Timeout

double JY5412CoreOO::JY5412CoreOODOWatchdogTask::Timeout

Timeout time, unit: seconds.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODOWatchdogTask.h


5412 COO Programming Manual: JY5412CoreOO::WatchdogChannel Class Reference

  • WatchdogChannel
Public Attributes | List of all members
JY5412CoreOO::WatchdogChannel Class Reference

WatchdogChannel class. More...

#include <JY5412CoreOODOWatchdogTask.h>

Public Attributes

int | PortID
PortID.
int | LineID
LineID.
WatchdogExpirationState ExpirationState
Watchdog expiration state.

Detailed Description

WatchdogChannel class

.

Member Data Documentation

◆ ExpirationState

WatchdogExpirationState JY5412CoreOO::WatchdogChannel::ExpirationState

Watchdog expiration state.

◆ LineID

int JY5412CoreOO::WatchdogChannel::LineID

LineID.

◆ PortID

int JY5412CoreOO::WatchdogChannel::PortID

PortID.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOODOWatchdogTask.h


5412 COO Programming Manual: C:/COO/JY5412CoreOOLog.h File Reference

  • File List
  • File Members
  • C:
  • COO
Classes | Namespaces | Enumerations
JY5412CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY5412CoreOOCommon.h"

Classes

class JY5412CoreOO::JY5412CoreOOLog

Namespaces

namespace JY5412CoreOO

Enumerations

enum class JY5412CoreOO::JY5412CoreOOLogLevel {
JY5412CoreOO::DEBUG_LOG_LEVEL , JY5412CoreOO::INFO_LOG_LEVEL , JY5412CoreOO::WARN_LOG_LEVEL , JY5412CoreOO::ERROR_LOG_LEVEL ,
JY5412CoreOO::FATAL_LOG_LEVEL
}


5412 COO Programming Manual: JY5412CoreOO::JY5412CoreOOLog Class Reference

  • JY5412CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5412CoreOO::JY5412CoreOOLog Class Reference

#include <JY5412CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5412CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5412CoreOOLogLevel | LogLevel
static JY5412CoreOOProperty< JY5412CoreOOLog, bool, JY5412CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

void JY5412CoreOO::JY5412CoreOOLog::Flush ( )
static

◆ Print() [1/2]

void JY5412CoreOO::JY5412CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

void JY5412CoreOO::JY5412CoreOOLog::Print | ( | JY5412CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5412CoreOOProperty<JY5412CoreOOLog, bool, JY5412CoreOOPropertyType::READ_WRITE> JY5412CoreOO::JY5412CoreOOLog::EnableLog
static

◆ LogLevel

JY5412CoreOOLogLevel JY5412CoreOO::JY5412CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOOLog.h


5412 COO Programming Manual: C:/COO/JY5412CoreOOPowerUpStates.h File Reference

  • File List
  • File Members
  • C:
  • COO
Classes | Namespaces | Enumerations
JY5412CoreOOPowerUpStates.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include <array>
#include "JY5412CoreOOCommon.h"

Classes

class | JY5412CoreOO::PortLogicLevelPowerUpStates
The class used to set the default logic level of the power-on state. More...
class | JY5412CoreOO::ChannelPowerUpStates
A class for setting the default power-on state of input or output. More...
class | JY5412CoreOO::JY5412PowerUpStates
Power-on state configuration. More...
class | JY5412CoreOO::Input_PowerUpStates
Input PowerUpStates param. More...
class | JY5412CoreOO::Output_PowerUpStates
Output PowerUpStates param. More...

Namespaces

namespace JY5412CoreOO

Enumerations

enum class JY5412CoreOO::PowerUpStateMode { JY5412CoreOO::Output , JY5412CoreOO::Input }
Input Mode. More...


5412 COO Programming Manual: JY5412CoreOO::PortLogicLevelPowerUpStates Class Reference

  • PortLogicLevelPowerUpStates
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::PortLogicLevelPowerUpStates Class Reference

The class used to set the default logic level of the power-on state. More...

#include <JY5412CoreOOPowerUpStates.h>

Public Member Functions

PortLogicLevelPowerUpStates ()
PortLogicLevelPowerUpStates (LogicLevel logiclevel)

Public Attributes

LogicLevel Logiclevel
LogicLevel.

Detailed Description

The class used to set the default logic level of the power-on state

.

Constructor & Destructor Documentation

◆ PortLogicLevelPowerUpStates() [1/2]

JY5412CoreOO::PortLogicLevelPowerUpStates::PortLogicLevelPowerUpStates ( )

◆ PortLogicLevelPowerUpStates() [2/2]

JY5412CoreOO::PortLogicLevelPowerUpStates::PortLogicLevelPowerUpStates ( LogicLevel logiclevel )
inline

Member Data Documentation

◆ Logiclevel

LogicLevel JY5412CoreOO::PortLogicLevelPowerUpStates::Logiclevel

LogicLevel.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOOPowerUpStates.h


5412 COO Programming Manual: JY5412CoreOO::ChannelPowerUpStates Class Reference

  • ChannelPowerUpStates
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::ChannelPowerUpStates Class Reference

A class for setting the default power-on state of input or output. More...

#include <JY5412CoreOOPowerUpStates.h>

Public Member Functions

ChannelPowerUpStates ()
Constructor.
ChannelPowerUpStates (PowerUpStateMode mode, Input_PowerUpStates *input_PowerUpStates)
ChannelPowerUpStates (PowerUpStateMode mode, Output_PowerUpStates *output_PowerUpStates)
~ChannelPowerUpStates ()

Public Attributes

PowerUpStateMode Mode
Set PowerUpStates as input or output.
Input_PowerUpStates * Input
Input PowerUpStates.
Output_PowerUpStates * Output
OutPut PowerUpStates.

Detailed Description

A class for setting the default power-on state of input or output

.

Constructor & Destructor Documentation

◆ ChannelPowerUpStates() [1/3]

JY5412CoreOO::ChannelPowerUpStates::ChannelPowerUpStates ( )

Constructor.

◆ ChannelPowerUpStates() [2/3]

JY5412CoreOO::ChannelPowerUpStates::ChannelPowerUpStates | ( | PowerUpStateMode | mode,
 |  | Input_PowerUpStates * | input_PowerUpStates )

◆ ChannelPowerUpStates() [3/3]

JY5412CoreOO::ChannelPowerUpStates::ChannelPowerUpStates | ( | PowerUpStateMode | mode,
 |  | Output_PowerUpStates * | output_PowerUpStates )

◆ ~ChannelPowerUpStates()

JY5412CoreOO::ChannelPowerUpStates::~ChannelPowerUpStates ( )

Member Data Documentation

◆ Input

Input_PowerUpStates* JY5412CoreOO::ChannelPowerUpStates::Input

Input PowerUpStates.

◆ Mode

PowerUpStateMode JY5412CoreOO::ChannelPowerUpStates::Mode

Set PowerUpStates as input or output.

The default setting is output.

◆ Output

Output_PowerUpStates* JY5412CoreOO::ChannelPowerUpStates::Output

OutPut PowerUpStates.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOOPowerUpStates.h


5412 COO Programming Manual: JY5412CoreOO::JY5412PowerUpStates Class Reference

  • JY5412PowerUpStates
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::JY5412PowerUpStates Class Reference

Power-on state configuration. More...

#include <JY5412CoreOOPowerUpStates.h>

Public Member Functions

JY5412PowerUpStates ()
constructor

Public Attributes

std::array< PortLogicLevelPowerUpStates, 4 > | Ports
An array used to set the default power-on state of the logic potential.
std::array< std::array< ChannelPowerUpStates, 24 >, 4 > | Channels
Set the array for the default power-on state of input or output.

Detailed Description

Power-on state configuration.

Constructor & Destructor Documentation

◆ JY5412PowerUpStates()

JY5412CoreOO::JY5412PowerUpStates::JY5412PowerUpStates ( )

constructor

Member Data Documentation

◆ Channels

std::array<std::array<ChannelPowerUpStates,24>, 4> JY5412CoreOO::JY5412PowerUpStates::Channels

Set the array for the default power-on state of input or output.

◆ Ports

std::array<PortLogicLevelPowerUpStates, 4> JY5412CoreOO::JY5412PowerUpStates::Ports

An array used to set the default power-on state of the logic potential.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOOPowerUpStates.h


5412 COO Programming Manual: JY5412CoreOO::Input_PowerUpStates Class Reference

  • Input_PowerUpStates
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::Input_PowerUpStates Class Reference

Input PowerUpStates param. More...

#include <JY5412CoreOOPowerUpStates.h>

Public Member Functions

Input_PowerUpStates (DITerminal terminal)

Public Attributes

DITerminal Terminal
Input mode.

Detailed Description

Input PowerUpStates param.

Constructor & Destructor Documentation

◆ Input_PowerUpStates()

JY5412CoreOO::Input_PowerUpStates::Input_PowerUpStates ( DITerminal terminal )
inline

Member Data Documentation

◆ Terminal

DITerminal JY5412CoreOO::Input_PowerUpStates::Terminal

Input mode.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOOPowerUpStates.h


5412 COO Programming Manual: JY5412CoreOO::Output_PowerUpStates Class Reference

  • Output_PowerUpStates
Public Member Functions | Public Attributes | List of all members
JY5412CoreOO::Output_PowerUpStates Class Reference

Output PowerUpStates param. More...

#include <JY5412CoreOOPowerUpStates.h>

Public Member Functions

Output_PowerUpStates (DOTerminal terminal, bool value)

Public Attributes

DOTerminal Terminal
Output Terminal.
bool Level
Output value.

Detailed Description

Output PowerUpStates param.

Constructor & Destructor Documentation

◆ Output_PowerUpStates()

JY5412CoreOO::Output_PowerUpStates::Output_PowerUpStates | ( | DOTerminal | terminal,
 |  | bool | value )
 inline

Member Data Documentation

◆ Level

bool JY5412CoreOO::Output_PowerUpStates::Level

Output value.

◆ Terminal

DOTerminal JY5412CoreOO::Output_PowerUpStates::Terminal

Output Terminal.

The documentation for this class was generated from the following file:
  • C:/COO/JY5412CoreOOPowerUpStates.h


5412 COO Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
N JY5412CoreOO |
C JYDriverException |
C JY5412CoreOOProperty | 属性模板类
C JY5412CoreOODevice |
C ChangeDetectionEventInfo |
C ChangeDetectionEventInformation |
C JY5412CoreOODIChangeDetectionTask |
C ChangeDetectionChannel | ChangeDetectionEvent Channel parameter class
C JY5412CoreOODITask |
C DIChannel | DI Channel parameter class
C JY5412CoreOODOTask |
C DOChannel | DO Channel parameter class
C JY5412CoreOODOWatchdogTask |
C WatchdogChannel | WatchdogChannel class
C JY5412CoreOOLog |
C PortLogicLevelPowerUpStates | The class used to set the default logic level of the power-on state
C ChannelPowerUpStates | A class for setting the default power-on state of input or output
C JY5412PowerUpStates | Power-on state configuration
C Input_PowerUpStates | Input PowerUpStates param
C Output_PowerUpStates | Output PowerUpStates param


5412 COO Programming Manual: Member List

  • ChangeDetectionChannel
JY5412CoreOO::ChangeDetectionChannel Member List

This is the complete list of members for JY5412CoreOO::ChangeDetectionChannel, including all inherited members.

ChangeDetection_Mode | JY5412CoreOO::ChangeDetectionChannel
EnableDigitalFilter | JY5412CoreOO::ChangeDetectionChannel
LineID | JY5412CoreOO::ChangeDetectionChannel
PortID | JY5412CoreOO::ChangeDetectionChannel
Terminal | JY5412CoreOO::ChangeDetectionChannel


5412 COO Programming Manual: Member List

  • ChangeDetectionEventInformation
JY5412CoreOO::ChangeDetectionEventInformation Member List

This is the complete list of members for JY5412CoreOO::ChangeDetectionEventInformation, including all inherited members.

JY5412CoreOODIChangeDetectionTask class | JY5412CoreOO::ChangeDetectionEventInformation | friend
Level | JY5412CoreOO::ChangeDetectionEventInformation |
LineID | JY5412CoreOO::ChangeDetectionEventInformation |
PortID | JY5412CoreOO::ChangeDetectionEventInformation |
UserData | JY5412CoreOO::ChangeDetectionEventInformation |


5412 COO Programming Manual: Member List

  • ChannelPowerUpStates
JY5412CoreOO::ChannelPowerUpStates Member List

This is the complete list of members for JY5412CoreOO::ChannelPowerUpStates, including all inherited members.

ChannelPowerUpStates() | JY5412CoreOO::ChannelPowerUpStates
ChannelPowerUpStates(PowerUpStateMode mode, Input_PowerUpStates *input_PowerUpStates) | JY5412CoreOO::ChannelPowerUpStates
ChannelPowerUpStates(PowerUpStateMode mode, Output_PowerUpStates *output_PowerUpStates) | JY5412CoreOO::ChannelPowerUpStates
Input | JY5412CoreOO::ChannelPowerUpStates
Mode | JY5412CoreOO::ChannelPowerUpStates
Output | JY5412CoreOO::ChannelPowerUpStates
~ChannelPowerUpStates() | JY5412CoreOO::ChannelPowerUpStates


5412 COO Programming Manual: Member List

  • DIChannel
JY5412CoreOO::DIChannel Member List

This is the complete list of members for JY5412CoreOO::DIChannel, including all inherited members.

EnableDigitalFilter | JY5412CoreOO::DIChannel
LineID | JY5412CoreOO::DIChannel
PortID | JY5412CoreOO::DIChannel
Terminal | JY5412CoreOO::DIChannel


5412 COO Programming Manual: Member List

  • DOChannel
JY5412CoreOO::DOChannel Member List

This is the complete list of members for JY5412CoreOO::DOChannel, including all inherited members.

LineID | JY5412CoreOO::DOChannel
Mode | JY5412CoreOO::DOChannel
PortID | JY5412CoreOO::DOChannel


5412 COO Programming Manual: Member List

  • Input_PowerUpStates
JY5412CoreOO::Input_PowerUpStates Member List

This is the complete list of members for JY5412CoreOO::Input_PowerUpStates, including all inherited members.

Input_PowerUpStates(DITerminal terminal) | JY5412CoreOO::Input_PowerUpStates | inline
Terminal | JY5412CoreOO::Input_PowerUpStates |


5412 COO Programming Manual: Member List

  • JY5412CoreOODIChangeDetectionTask
JY5412CoreOO::JY5412CoreOODIChangeDetectionTask Member List

This is the complete list of members for JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, including all inherited members.

AddChannel(int portID, int lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
AddChannel(int portID, std::vector< int > &lineID, ChangeDetectionMode changeDetectionMode, DITerminal terminal, bool enableDigitalFilter=false) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
AddChannel(int portID, std::vector< int > &lineID, std::vector< ChangeDetectionMode > &changeDetectionMode, std::vector< DITerminal > &terminal, std::vector< bool > &enableDigitalFilter) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, std::vector< ChangeDetectionMode > &changeDetectionMode, std::vector< DITerminal > &terminal, bool enableDigitalFilter=false) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, std::vector< ChangeDetectionMode > &changeDetectionMode, std::vector< DITerminal > &terminal, std::vector< bool > &enableDigitalFilter) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
ChangeDetected | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask | static
Channels | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
Device | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
JY5412CoreOODIChangeDetectionTask(int slotNum) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
JY5412CoreOODIChangeDetectionTask(std::string &boardName) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
ReadSinglePoint(bool &readValues, int portID, int lineID) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
ReadSinglePoint(bool *readValues) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
ReadSinglePoint(std::vector< bool > &readValues) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
RemoveChannel(int portID, int lineID) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
RemoveChannel(std::vector< int > &portID, std::vector< int > &lineID) | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
Start() | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
Stop() | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
UserData | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |
~JY5412CoreOODIChangeDetectionTask() | JY5412CoreOO::JY5412CoreOODIChangeDetectionTask |


5412 COO Programming Manual: Member List

  • JY5412CoreOODITask
JY5412CoreOO::JY5412CoreOODITask Member List

This is the complete list of members for JY5412CoreOO::JY5412CoreOODITask, including all inherited members.

AddChannel(int portID, int lineID, DITerminal terminal, bool enableDigitalFilter=false) | JY5412CoreOO::JY5412CoreOODITask
AddChannel(int portID, std::vector< int > &lineID, DITerminal terminal, bool enableDigitalFilter=false) | JY5412CoreOO::JY5412CoreOODITask
AddChannel(int portID, std::vector< int > &lineID, std::vector< DITerminal > &terminal, std::vector< bool > &enableDigitalFilter) | JY5412CoreOO::JY5412CoreOODITask
AddChannel(int portID, std::vector< int > &lineID, std::vector< DITerminal > &terminal) | JY5412CoreOO::JY5412CoreOODITask
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, std::vector< DITerminal > &terminal, bool enableDigitalFilter=false) | JY5412CoreOO::JY5412CoreOODITask
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, std::vector< DITerminal > &terminal, std::vector< bool > &enableDigitalFilter) | JY5412CoreOO::JY5412CoreOODITask
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, DITerminal terminal, bool enableDigitalFilter=false) | JY5412CoreOO::JY5412CoreOODITask
Channels | JY5412CoreOO::JY5412CoreOODITask
Device | JY5412CoreOO::JY5412CoreOODITask
JY5412CoreOODITask(int slotNum) | JY5412CoreOO::JY5412CoreOODITask
JY5412CoreOODITask(std::string &boardName) | JY5412CoreOO::JY5412CoreOODITask
ReadSinglePoint(bool &readValues, int portID, int lineID) | JY5412CoreOO::JY5412CoreOODITask
ReadSinglePoint(bool *readValues) | JY5412CoreOO::JY5412CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues) | JY5412CoreOO::JY5412CoreOODITask
RemoveChannel(int portID, int lineID) | JY5412CoreOO::JY5412CoreOODITask
RemoveChannel(std::vector< int > &portID, std::vector< int > &lineID) | JY5412CoreOO::JY5412CoreOODITask
~JY5412CoreOODITask() | JY5412CoreOO::JY5412CoreOODITask


5412 COO Programming Manual: Member List

  • JY5412CoreOODOTask
JY5412CoreOO::JY5412CoreOODOTask Member List

This is the complete list of members for JY5412CoreOO::JY5412CoreOODOTask, including all inherited members.

AddChannel(int portID, int lineID, DOTerminal mode) | JY5412CoreOO::JY5412CoreOODOTask
AddChannel(int portID, std::vector< int > &lineID, DOTerminal mode) | JY5412CoreOO::JY5412CoreOODOTask
AddChannel(int portID, std::vector< int > &lineID, std::vector< DOTerminal > &mode) | JY5412CoreOO::JY5412CoreOODOTask
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, std::vector< DOTerminal > &mode) | JY5412CoreOO::JY5412CoreOODOTask
AddChannel(std::vector< int > &portID, int lineID, DOTerminal mode) | JY5412CoreOO::JY5412CoreOODOTask
AddChannel(std::vector< int > &portID, int lineID, std::vector< DOTerminal > &mode) | JY5412CoreOO::JY5412CoreOODOTask
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, DOTerminal mode) | JY5412CoreOO::JY5412CoreOODOTask
Channels | JY5412CoreOO::JY5412CoreOODOTask
Device | JY5412CoreOO::JY5412CoreOODOTask
JY5412CoreOODOTask(int slotNum) | JY5412CoreOO::JY5412CoreOODOTask
JY5412CoreOODOTask(std::string &boardName) | JY5412CoreOO::JY5412CoreOODOTask
RemoveChannel(int portID, int lineID) | JY5412CoreOO::JY5412CoreOODOTask
RemoveChannel(std::vector< int > &portID, std::vector< int > &lineID) | JY5412CoreOO::JY5412CoreOODOTask
WriteSinglePoint(bool writeValue, int portID, int lineID) | JY5412CoreOO::JY5412CoreOODOTask
WriteSinglePoint(bool *writeValues) | JY5412CoreOO::JY5412CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5412CoreOO::JY5412CoreOODOTask
~JY5412CoreOODOTask() | JY5412CoreOO::JY5412CoreOODOTask


5412 COO Programming Manual: Member List

  • JY5412CoreOODOWatchdogTask
JY5412CoreOO::JY5412CoreOODOWatchdogTask Member List

This is the complete list of members for JY5412CoreOO::JY5412CoreOODOWatchdogTask, including all inherited members.

AddChannel(int portID, int lineID, WatchdogExpirationState expirationState) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
AddChannel(int portID, std::vector< int > &lineID, WatchdogExpirationState expirationState) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
AddChannel(int portID, std::vector< int > &lineID, std::vector< WatchdogExpirationState > &expirationState) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, std::vector< WatchdogExpirationState > &expirationState) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
AddChannel(std::vector< int > &portID, int lineID, WatchdogExpirationState expirationState) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
AddChannel(std::vector< int > &portID, int lineID, std::vector< WatchdogExpirationState > &expirationState) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
AddChannel(std::vector< int > &portID, std::vector< int > &lineID, WatchdogExpirationState expirationState) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
Channels | JY5412CoreOO::JY5412CoreOODOWatchdogTask
ClearExpiration() | JY5412CoreOO::JY5412CoreOODOWatchdogTask
Commit() | JY5412CoreOO::JY5412CoreOODOWatchdogTask
Device | JY5412CoreOO::JY5412CoreOODOWatchdogTask
Expired | JY5412CoreOO::JY5412CoreOODOWatchdogTask
JY5412CoreOODOWatchdogTask(int slotNum) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
JY5412CoreOODOWatchdogTask(std::string &boardName) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
RemoveChannel(int portID, int lineID) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
RemoveChannel(std::vector< int > &portID, std::vector< int > &lineID) | JY5412CoreOO::JY5412CoreOODOWatchdogTask
ResetTimer() | JY5412CoreOO::JY5412CoreOODOWatchdogTask
Start() | JY5412CoreOO::JY5412CoreOODOWatchdogTask
Stop() | JY5412CoreOO::JY5412CoreOODOWatchdogTask
Timeout | JY5412CoreOO::JY5412CoreOODOWatchdogTask
~JY5412CoreOODOWatchdogTask() | JY5412CoreOO::JY5412CoreOODOWatchdogTask


5412 COO Programming Manual: Member List

  • JY5412CoreOODevice
JY5412CoreOO::JY5412CoreOODevice Member List

This is the complete list of members for JY5412CoreOO::JY5412CoreOODevice, including all inherited members.

GetInstance(int cardNum) | JY5412CoreOO::JY5412CoreOODevice | static
GetInstance(std::string aliasName) | JY5412CoreOO::JY5412CoreOODevice | static
GetPowerUpStates(JY5412PowerUpStates &powerUpStates) | JY5412CoreOO::JY5412CoreOODevice |
Handle | JY5412CoreOO::JY5412CoreOODevice |
NumberOfPorts | JY5412CoreOO::JY5412CoreOODevice | static
NumOfLinesPerPort | JY5412CoreOO::JY5412CoreOODevice | static
Release() | JY5412CoreOO::JY5412CoreOODevice |
SetLogicLevel(int portID, LogicLevel logiclevel) | JY5412CoreOO::JY5412CoreOODevice |
SetLogicLevel(std::vector< int > &portID, std::vector< LogicLevel > &logiclevel) | JY5412CoreOO::JY5412CoreOODevice |
SetMinPulseWidth(int portID, int minePulseWidth) | JY5412CoreOO::JY5412CoreOODevice |
SetMinPulseWidth(std::vector< int > &portID, std::vector< int > &minePulseWidth) | JY5412CoreOO::JY5412CoreOODevice |
SetPowerUpStates(JY5412PowerUpStates *powerUpStates) | JY5412CoreOO::JY5412CoreOODevice |
SetPowerUpStates(JY5412PowerUpStates &powerUpStates) | JY5412CoreOO::JY5412CoreOODevice |


5412 COO Programming Manual: Member List

  • JY5412CoreOOLog
JY5412CoreOO::JY5412CoreOOLog Member List

This is the complete list of members for JY5412CoreOO::JY5412CoreOOLog, including all inherited members.

EnableLog | JY5412CoreOO::JY5412CoreOOLog | static
Flush() | JY5412CoreOO::JY5412CoreOOLog | static
LogLevel | JY5412CoreOO::JY5412CoreOOLog | static
Print(const char *format,...) | JY5412CoreOO::JY5412CoreOOLog | static
Print(JY5412CoreOOLogLevel logLevel, const char *format,...) | JY5412CoreOO::JY5412CoreOOLog | static


5412 COO Programming Manual: Member List

  • JY5412CoreOOProperty
JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5412CoreOOProperty() | JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5412CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5412CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
~JY5412CoreOOProperty() | JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >


5412 COO Programming Manual: Member List

  • JY5412PowerUpStates
JY5412CoreOO::JY5412PowerUpStates Member List

This is the complete list of members for JY5412CoreOO::JY5412PowerUpStates, including all inherited members.

Channels | JY5412CoreOO::JY5412PowerUpStates
JY5412PowerUpStates() | JY5412CoreOO::JY5412PowerUpStates
Ports | JY5412CoreOO::JY5412PowerUpStates


5412 COO Programming Manual: Member List

  • JYDriverException
JY5412CoreOO::JYDriverException Member List

This is the complete list of members for JY5412CoreOO::JYDriverException, including all inherited members.

errorCode | JY5412CoreOO::JYDriverException
exceptionMessage | JY5412CoreOO::JYDriverException
FollowingException | JY5412CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5412CoreOO::JYDriverException
JYDriverException(JYErrorCode exceptionCode, std::string msg="") | JY5412CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5412CoreOO::JYDriverException


5412 COO Programming Manual: Member List

  • Output_PowerUpStates
JY5412CoreOO::Output_PowerUpStates Member List

This is the complete list of members for JY5412CoreOO::Output_PowerUpStates, including all inherited members.

Level | JY5412CoreOO::Output_PowerUpStates |
Output_PowerUpStates(DOTerminal terminal, bool value) | JY5412CoreOO::Output_PowerUpStates | inline
Terminal | JY5412CoreOO::Output_PowerUpStates |


5412 COO Programming Manual: Member List

  • PortLogicLevelPowerUpStates
JY5412CoreOO::PortLogicLevelPowerUpStates Member List

This is the complete list of members for JY5412CoreOO::PortLogicLevelPowerUpStates, including all inherited members.

Logiclevel | JY5412CoreOO::PortLogicLevelPowerUpStates |
PortLogicLevelPowerUpStates() | JY5412CoreOO::PortLogicLevelPowerUpStates |
PortLogicLevelPowerUpStates(LogicLevel logiclevel) | JY5412CoreOO::PortLogicLevelPowerUpStates | inline


5412 COO Programming Manual: Member List

  • WatchdogChannel
JY5412CoreOO::WatchdogChannel Member List

This is the complete list of members for JY5412CoreOO::WatchdogChannel, including all inherited members.

ExpirationState | JY5412CoreOO::WatchdogChannel
LineID | JY5412CoreOO::WatchdogChannel
PortID | JY5412CoreOO::WatchdogChannel


5412 COO Programming Manual: Class Index

Class Index
C | D | I | J | O | P | W
C
ChangeDetectionChannel (JY5412CoreOO)
ChangeDetectionEventInfo (JY5412CoreOO)
ChangeDetectionEventInformation (JY5412CoreOO)
ChannelPowerUpStates (JY5412CoreOO)
D
DIChannel (JY5412CoreOO)
DOChannel (JY5412CoreOO)
I
Input_PowerUpStates (JY5412CoreOO)
J
JY5412CoreOODevice (JY5412CoreOO)
JY5412CoreOODIChangeDetectionTask (JY5412CoreOO)
JY5412CoreOODITask (JY5412CoreOO)
JY5412CoreOODOTask (JY5412CoreOO)
JY5412CoreOODOWatchdogTask (JY5412CoreOO)
JY5412CoreOOLog (JY5412CoreOO)
JY5412CoreOOProperty (JY5412CoreOO)
JY5412PowerUpStates (JY5412CoreOO)
JYDriverException (JY5412CoreOO)
O
Output_PowerUpStates (JY5412CoreOO)
P
PortLogicLevelPowerUpStates (JY5412CoreOO)
W
WatchdogChannel (JY5412CoreOO)


5412 COO Programming Manual: C: Directory Reference

  • File List
  • File Members
  • C:
C: Directory Reference

Directories

         COO


5412 COO Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
 C:
COO
JY5412CoreOOCommon.h
JY5412CoreOODevice.h
JY5412CoreOODIChangeDetectionTask.h
JY5412CoreOODITask.h
JY5412CoreOODOTask.h
JY5412CoreOODOWatchdogTask.h
JY5412CoreOOLog.h
JY5412CoreOOPowerUpStates.h


5412 COO Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • AddChannel() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask, JY5412CoreOO::JY5412CoreOODOTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask

- c -

  • ChangeDetected : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask
  • ChangeDetection_Mode : JY5412CoreOO::ChangeDetectionChannel
  • ChannelPowerUpStates() : JY5412CoreOO::ChannelPowerUpStates
  • Channels : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask, JY5412CoreOO::JY5412CoreOODOTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask, JY5412CoreOO::JY5412PowerUpStates
  • ClearExpiration() : JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • Commit() : JY5412CoreOO::JY5412CoreOODOWatchdogTask

- d -

  • Device : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask, JY5412CoreOO::JY5412CoreOODOTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask

- e -

  • EnableDigitalFilter : JY5412CoreOO::ChangeDetectionChannel, JY5412CoreOO::DIChannel
  • EnableLog : JY5412CoreOO::JY5412CoreOOLog
  • errorCode : JY5412CoreOO::JYDriverException
  • exceptionMessage : JY5412CoreOO::JYDriverException
  • ExpirationState : JY5412CoreOO::WatchdogChannel
  • Expired : JY5412CoreOO::JY5412CoreOODOWatchdogTask

- f -

  • Flush() : JY5412CoreOO::JY5412CoreOOLog
  • FollowingException : JY5412CoreOO::JYDriverException

- g -

  • GetInstance() : JY5412CoreOO::JY5412CoreOODevice
  • GetPowerUpStates() : JY5412CoreOO::JY5412CoreOODevice

- h -

  • Handle : JY5412CoreOO::JY5412CoreOODevice

- i -

  • Input : JY5412CoreOO::ChannelPowerUpStates
  • Input_PowerUpStates() : JY5412CoreOO::Input_PowerUpStates

- j -

  • JY5412CoreOODIChangeDetectionTask : JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::JY5412CoreOODIChangeDetectionTask
  • JY5412CoreOODITask() : JY5412CoreOO::JY5412CoreOODITask
  • JY5412CoreOODOTask() : JY5412CoreOO::JY5412CoreOODOTask
  • JY5412CoreOODOWatchdogTask() : JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • JY5412CoreOOProperty() : JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY5412PowerUpStates() : JY5412CoreOO::JY5412PowerUpStates
  • JYDriverException() : JY5412CoreOO::JYDriverException

- l -

  • Level : JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::Output_PowerUpStates
  • lineChanged : JY5412CoreOO::ChangeDetectionEventInfo
  • LineID : JY5412CoreOO::ChangeDetectionChannel, JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::DIChannel, JY5412CoreOO::DOChannel, JY5412CoreOO::WatchdogChannel
  • lineLevel : JY5412CoreOO::ChangeDetectionEventInfo
  • Logiclevel : JY5412CoreOO::PortLogicLevelPowerUpStates
  • LogLevel : JY5412CoreOO::JY5412CoreOOLog

- m -

  • Mode : JY5412CoreOO::ChannelPowerUpStates, JY5412CoreOO::DOChannel

- n -

  • NumberOfPorts : JY5412CoreOO::JY5412CoreOODevice
  • NumOfLinesPerPort : JY5412CoreOO::JY5412CoreOODevice

- o -

  • operator ValueType() : JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
  • Output : JY5412CoreOO::ChannelPowerUpStates
  • Output_PowerUpStates() : JY5412CoreOO::Output_PowerUpStates

- p -

  • PortID : JY5412CoreOO::ChangeDetectionChannel, JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::DIChannel, JY5412CoreOO::DOChannel, JY5412CoreOO::WatchdogChannel
  • PortLogicLevelPowerUpStates() : JY5412CoreOO::PortLogicLevelPowerUpStates
  • Ports : JY5412CoreOO::JY5412PowerUpStates
  • Print() : JY5412CoreOO::JY5412CoreOOLog

- r -

  • ReadSinglePoint() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask
  • Release() : JY5412CoreOO::JY5412CoreOODevice
  • RemoveChannel() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask, JY5412CoreOO::JY5412CoreOODOTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • ResetTimer() : JY5412CoreOO::JY5412CoreOODOWatchdogTask

- s -

  • SetLogicLevel() : JY5412CoreOO::JY5412CoreOODevice
  • SetMinPulseWidth() : JY5412CoreOO::JY5412CoreOODevice
  • SetPowerUpStates() : JY5412CoreOO::JY5412CoreOODevice
  • Start() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • Stop() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask

- t -

  • Terminal : JY5412CoreOO::ChangeDetectionChannel, JY5412CoreOO::DIChannel, JY5412CoreOO::Input_PowerUpStates, JY5412CoreOO::Output_PowerUpStates
  • Timeout : JY5412CoreOO::JY5412CoreOODOWatchdogTask

- u -

  • UserData : JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::JY5412CoreOODIChangeDetectionTask

- w -

  • WriteSinglePoint() : JY5412CoreOO::JY5412CoreOODOTask

- ~ -

  • ~ChannelPowerUpStates() : JY5412CoreOO::ChannelPowerUpStates
  • ~JY5412CoreOODIChangeDetectionTask() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask
  • ~JY5412CoreOODITask() : JY5412CoreOO::JY5412CoreOODITask
  • ~JY5412CoreOODOTask() : JY5412CoreOO::JY5412CoreOODOTask
  • ~JY5412CoreOODOWatchdogTask() : JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • ~JY5412CoreOOProperty() : JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >


5412 COO Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • c
  • f
  • g
  • i
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • AddChannel() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask, JY5412CoreOO::JY5412CoreOODOTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask

- c -

  • ChannelPowerUpStates() : JY5412CoreOO::ChannelPowerUpStates
  • ClearExpiration() : JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • Commit() : JY5412CoreOO::JY5412CoreOODOWatchdogTask

- f -

  • Flush() : JY5412CoreOO::JY5412CoreOOLog

- g -

  • GetInstance() : JY5412CoreOO::JY5412CoreOODevice
  • GetPowerUpStates() : JY5412CoreOO::JY5412CoreOODevice

- i -

  • Input_PowerUpStates() : JY5412CoreOO::Input_PowerUpStates

- j -

  • JY5412CoreOODIChangeDetectionTask() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask
  • JY5412CoreOODITask() : JY5412CoreOO::JY5412CoreOODITask
  • JY5412CoreOODOTask() : JY5412CoreOO::JY5412CoreOODOTask
  • JY5412CoreOODOWatchdogTask() : JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • JY5412CoreOOProperty() : JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY5412PowerUpStates() : JY5412CoreOO::JY5412PowerUpStates
  • JYDriverException() : JY5412CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >
  • Output_PowerUpStates() : JY5412CoreOO::Output_PowerUpStates

- p -

  • PortLogicLevelPowerUpStates() : JY5412CoreOO::PortLogicLevelPowerUpStates
  • Print() : JY5412CoreOO::JY5412CoreOOLog

- r -

  • ReadSinglePoint() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask
  • Release() : JY5412CoreOO::JY5412CoreOODevice
  • RemoveChannel() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask, JY5412CoreOO::JY5412CoreOODOTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • ResetTimer() : JY5412CoreOO::JY5412CoreOODOWatchdogTask

- s -

  • SetLogicLevel() : JY5412CoreOO::JY5412CoreOODevice
  • SetMinPulseWidth() : JY5412CoreOO::JY5412CoreOODevice
  • SetPowerUpStates() : JY5412CoreOO::JY5412CoreOODevice
  • Start() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • Stop() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask

- w -

  • WriteSinglePoint() : JY5412CoreOO::JY5412CoreOODOTask

- ~ -

  • ~ChannelPowerUpStates() : JY5412CoreOO::ChannelPowerUpStates
  • ~JY5412CoreOODIChangeDetectionTask() : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask
  • ~JY5412CoreOODITask() : JY5412CoreOO::JY5412CoreOODITask
  • ~JY5412CoreOODOTask() : JY5412CoreOO::JY5412CoreOODOTask
  • ~JY5412CoreOODOWatchdogTask() : JY5412CoreOO::JY5412CoreOODOWatchdogTask
  • ~JY5412CoreOOProperty() : JY5412CoreOO::JY5412CoreOOProperty< ContainerClass, ValueType, propertyType >


5412 COO Programming Manual: Class Members - Related Symbols

  • All
  • Functions
  • Variables
  • Related Symbols
Here is a list of all related symbols with links to the classes they belong to:
  • JY5412CoreOODIChangeDetectionTask : JY5412CoreOO::ChangeDetectionEventInformation


5412 COO Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • t
  • u
Here is a list of all variables with links to the classes they belong to:

- c -

  • ChangeDetected : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask
  • ChangeDetection_Mode : JY5412CoreOO::ChangeDetectionChannel
  • Channels : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask, JY5412CoreOO::JY5412CoreOODOTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask, JY5412CoreOO::JY5412PowerUpStates

- d -

  • Device : JY5412CoreOO::JY5412CoreOODIChangeDetectionTask, JY5412CoreOO::JY5412CoreOODITask, JY5412CoreOO::JY5412CoreOODOTask, JY5412CoreOO::JY5412CoreOODOWatchdogTask

- e -

  • EnableDigitalFilter : JY5412CoreOO::ChangeDetectionChannel, JY5412CoreOO::DIChannel
  • EnableLog : JY5412CoreOO::JY5412CoreOOLog
  • errorCode : JY5412CoreOO::JYDriverException
  • exceptionMessage : JY5412CoreOO::JYDriverException
  • ExpirationState : JY5412CoreOO::WatchdogChannel
  • Expired : JY5412CoreOO::JY5412CoreOODOWatchdogTask

- f -

  • FollowingException : JY5412CoreOO::JYDriverException

- h -

  • Handle : JY5412CoreOO::JY5412CoreOODevice

- i -

  • Input : JY5412CoreOO::ChannelPowerUpStates

- l -

  • Level : JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::Output_PowerUpStates
  • lineChanged : JY5412CoreOO::ChangeDetectionEventInfo
  • LineID : JY5412CoreOO::ChangeDetectionChannel, JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::DIChannel, JY5412CoreOO::DOChannel, JY5412CoreOO::WatchdogChannel
  • lineLevel : JY5412CoreOO::ChangeDetectionEventInfo
  • Logiclevel : JY5412CoreOO::PortLogicLevelPowerUpStates
  • LogLevel : JY5412CoreOO::JY5412CoreOOLog

- m -

  • Mode : JY5412CoreOO::ChannelPowerUpStates, JY5412CoreOO::DOChannel

- n -

  • NumberOfPorts : JY5412CoreOO::JY5412CoreOODevice
  • NumOfLinesPerPort : JY5412CoreOO::JY5412CoreOODevice

- o -

  • Output : JY5412CoreOO::ChannelPowerUpStates

- p -

  • PortID : JY5412CoreOO::ChangeDetectionChannel, JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::DIChannel, JY5412CoreOO::DOChannel, JY5412CoreOO::WatchdogChannel
  • Ports : JY5412CoreOO::JY5412PowerUpStates

- t -

  • Terminal : JY5412CoreOO::ChangeDetectionChannel, JY5412CoreOO::DIChannel, JY5412CoreOO::Input_PowerUpStates, JY5412CoreOO::Output_PowerUpStates
  • Timeout : JY5412CoreOO::JY5412CoreOODOWatchdogTask

- u -

  • UserData : JY5412CoreOO::ChangeDetectionEventInformation, JY5412CoreOO::JY5412CoreOODIChangeDetectionTask


5412 COO Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY5412CoreOOCommon.h
  • JY5412CoreOO_API : JY5412CoreOOCommon.h


5412 COO Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY5412CoreOOCommon.h
  • JY5412CoreOO_API : JY5412CoreOOCommon.h


5412 COO Programming Manual: Main Page

5412 COO Programming Manual Documentation


5412 COO Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
  • b
  • c
  • d
  • e
  • f
  • h
  • j
  • l
  • n
  • o
  • p
  • r
  • t
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- b -

  • BothEdge : JY5412Import

- c -

  • ChangeDetectionEvent : JY5412Import
  • ChangeDetectionMode : JY5412CoreOO
  • CMOS3V3 : JY5412Import
  • CMOS5V0 : JY5412Import

- d -

  • DITerminal : JY5412CoreOO
  • DOTerminal : JY5412CoreOO

- e -

  • EventCounter : JY5412Import

- f -

  • FallingEdge : JY5412Import
  • Floating : JY5412Import

- h -

  • High : JY5412Import

- j -

  • JY5412CoreOO_CallbackFunc : JY5412CoreOO
  • JY5412CoreOOLogLevel : JY5412CoreOO
  • JY5412CoreOOPropertyType : JY5412CoreOO
  • JYDriverExceptionPublic : JY5412CoreOO
  • JYErrorCode : JY5412CoreOO

- l -

  • LinesCOS : JY5412Import
  • LineXOrnLineY : JY5412Import
  • LogicLevel : JY5412CoreOO
  • Low : JY5412Import

- n -

  • NoChange : JY5412Import

- o -

  • OpenDrain : JY5412Import

- p -

  • PowerUpStateMode : JY5412CoreOO
  • private_CallbackFunc : JY5412CoreOO
  • PullDown : JY5412Import
  • PullUp : JY5412Import
  • PushPull : JY5412Import

- r -

  • RisingEdge : JY5412Import

- t -

  • Timer : JY5412Import
  • Tristate : JY5412Import

- w -

  • WatchdogExpirationState : JY5412CoreOO


5412 COO Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • ChangeDetectionMode : JY5412CoreOO
  • DITerminal : JY5412CoreOO
  • DOTerminal : JY5412CoreOO
  • JY5412CoreOOLogLevel : JY5412CoreOO
  • JY5412CoreOOPropertyType : JY5412CoreOO
  • JYDriverExceptionPublic : JY5412CoreOO
  • JYErrorCode : JY5412CoreOO
  • LogicLevel : JY5412CoreOO
  • PowerUpStateMode : JY5412CoreOO
  • WatchdogExpirationState : JY5412CoreOO


5412 COO Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
Here is a list of all namespace typedefs with links to the namespace documentation for each typedef:
  • JY5412CoreOO_CallbackFunc : JY5412CoreOO
  • private_CallbackFunc : JY5412CoreOO


5412 COO Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Typedefs
  • Enumerations
Here is a list of all namespace variables with links to the namespace documentation for each variable:
  • BothEdge : JY5412Import
  • ChangeDetectionEvent : JY5412Import
  • CMOS3V3 : JY5412Import
  • CMOS5V0 : JY5412Import
  • EventCounter : JY5412Import
  • FallingEdge : JY5412Import
  • Floating : JY5412Import
  • High : JY5412Import
  • LinesCOS : JY5412Import
  • LineXOrnLineY : JY5412Import
  • Low : JY5412Import
  • NoChange : JY5412Import
  • OpenDrain : JY5412Import
  • PullDown : JY5412Import
  • PullUp : JY5412Import
  • PushPull : JY5412Import
  • RisingEdge : JY5412Import
  • Timer : JY5412Import
  • Tristate : JY5412Import


5412 COO Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5412CoreOO
N JY5412Import


5412 COO Programming Manual: Member List

  • ChangeDetectionEventInfo
JY5412CoreOO::ChangeDetectionEventInfo Member List

This is the complete list of members for JY5412CoreOO::ChangeDetectionEventInfo, including all inherited members.

lineChanged | JY5412CoreOO::ChangeDetectionEventInfo
lineLevel | JY5412CoreOO::ChangeDetectionEventInfo